INVESTIGATING: Service Disruption

Incident Report for Omeda - Status Page

Resolved

This incident has been resolved.
Posted May 13, 2026 - 01:18 CDT

Investigating

We are currently experiencing a service disruption impacting the Odyssey and Email Builder and are actively investigating the issue.
Posted May 12, 2026 - 19:39 CDT
This incident affected: Email and Odyssey.